落書きノート

ふと自分が気になった事を書いてます

Ubuntu 16.04でgem updateのエラー

Ubuntu付属のRubyでGemのアップデートをすると失敗しました。ログを見て検索していると解決。以下のエラーが出ていました。

mkmf.rb can't find header files for ruby

以下のライブラリをインストールしたら直りました。

# sudo apt install ruby-dev

*追記

RailsをGemでインストールしようとすると、Nokogiriのビルドに失敗します。

# sudo apt install zlib1g-dev

上記で解決出来ます。